Is anyone else having this glitch? It won't update needs and...

Guru
| I am here to help!
Is anyone else having this glitch? It won't update needs and says I'm on an older iOS and I'm not
Posted on: 03 Sep 2017

  
Recommendations and Suggestions
AWARDED
Guru
| I am here to help!
					You should update from apple App Store. 

It is not ios that is old but your needs app and u need to click the Apple Appstore icon to find the needs app. It should have an update option right there					
Posted: 13 months ago   Like: 1 folks   Comments: 4
Guru
| I am here to help!
				As I told the last poster it won't allow me to as it says I'm on an old iOS when I'm not.				
Posted: 13 months ago   Loved by: 0
Guru
| I am here to help!
				It said it cannot give me the newest version and just re updates to the version before. It claims my iOS is too old for the new version but I'm on the newest version.				
Posted: 13 months ago   Loved by: 0
Guru
| I am here to help!
				Thats weird. Report the problem using settings.				
Posted: 13 months ago   Loved by: 1
Guru
| I am here to help!
				Did so				
Posted: 13 months ago   Loved by: 0
Leader
| Stay at home mom who loves my money apps!
					I havent					
Posted: 13 months ago   Like: 1 folks   Comments: 0
Professional
| www.surpriseincandles.com
					Odd					
Posted: 13 months ago   Like: 2 folks   Comments: 2
Guru
| I am here to help!
				Yeah and no clue whom to Blaine				
Posted: 13 months ago   Loved by: 0
Guru
| I am here to help!
				Blame				
Posted: 13 months ago   Loved by: 0
Veteran
| I am here to help!
					Go to App Store and search for Needs.do
You should see the update option there					
Posted: 13 months ago   Like: 4 folks   Comments: 1
Guru
| I am here to help!
				It won't let me as it says I'm on a version before 10.3.3 but my phone itself is on 10.3.3 so I don't know how to fix that or if its App Store problem or Needs...				
Posted: 13 months ago   Loved by: 1